Newton Agent History Latency

Incident Report for Magic

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 11:58 PDT

Identified

We've identified an issue causing latency with the Newton Agent History. A fix is in the works.
Posted Jun 11, 2025 - 10:26 PDT
This incident affected: Newton Agents.