Email Sending Delays to Yahoo!, AOL and Verizon
Incident Report for Magic
Resolved
Email delivery to Yahoo!, AOL, Verizon hosted email addresses is back to operational. The incident is now resolved.
Posted May 30, 2021 - 17:43 PDT
Update
We've implemented a workaround to further improve our email deliverability to Yahoo!, AOL, and Verizon hosted emails. Continue to monitor the overall delivery performance.

Next update will be in 15 mins.
Posted May 30, 2021 - 16:58 PDT
Update
We are continuing to work with our email providers and to monitor the issue. We've seen an overall delivery improvement to Verizon hosted email addresses.
Posted May 30, 2021 - 10:54 PDT
Monitoring
The email delay to Yahoo!/AOL/Verizon has been confirmed to be related to the config change on the Verison side. We are continuing to monitor the email delivery to those hosted email addresses.
Posted May 29, 2021 - 21:09 PDT
Identified
Our email service providers are experiencing email sending delays to Yahoo!, AOL and Verizon. We are working with our providers to resolve the issue.
Posted May 29, 2021 - 18:26 PDT
This incident affected: Email Delivery (Postmark Outbound SMTP).