AWS Internet Connectivity Issues
Incident Report for Magic
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 08:35 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2021 - 08:19 PST
Identified
AWS has identified the root cause of the Internet connectivity issues and has taken steps to begin restoring connectivity.
Posted Dec 15, 2021 - 08:08 PST
Update
We are continuing to investigate this issue.
Posted Dec 15, 2021 - 07:53 PST
Investigating
We're seeing elevated error rates due to network issues stemming from an AWS network connectivity incident.
Posted Dec 15, 2021 - 07:52 PST
This incident affected: Authentication, API, Dashboard, Homepage, Documentation, Email Delivery (Postmark Outbound SMTP, Customer.io Email Sending), Content Delivery (magic.js CDN, magic-sdk NPM, npm, Inc. Registry Reads), Operations (AWS ec2-us-west-2, AWS elasticache-us-west-2, AWS elb-us-west-2, AWS lambda-us-west-2, AWS rds-us-west-2, AWS s3-us-west-2, AWS sqs-us-west-2), Data Processing (Segment Data Processing Pipeline, Segment Destinations, Segment Data Ingestion (Tracking) API, Customer.io Data Processing, Customer.io Data Collection), and Payment (Stripe API).