Email delivery delay
Incident Report for Magic
Resolved
This incident has been resolved.
Posted Apr 21, 2021 - 19:51 PDT
Monitoring
The degraded performance issue has been addressed. We are monitoring.
Posted Apr 21, 2021 - 19:44 PDT
Investigating
We're experiencing an email delay and are currently looking into the issue.
Posted Apr 21, 2021 - 19:37 PDT
This incident affected: Email Delivery (Postmark Outbound SMTP).